ESQUECEU SUAS INFORMAÇÕES?

TUTORIAL COMPLETO SOBRE PROCV NO EXCEL

/ / Fórmulas

O PROCV é uma das funções mais utilizadas no Excel e é empregada para fazer uma consulta (obedecendo um critério) em uma tabela, retornando um valor específico. Nesse tutorial, você terá um tutorial completo para se tornar expert no assunto.

DEFINIÇÃO

A função PROCV pode ser definida como uma consulta em uma tabela, daí vem o nome PROCV. O "V" significa Vertical, definido que a procura será na vertical. A sintaxe da fórmula é:

=PROCV( valor pesquisado ; intervalo ; número da coluna ; exato ou aproximado )

 

Fizemos um tutorial bem completo com muita explicação. Para organizar, separamos em blocos que você pode consultar separadamente.

Considerando a tabela de dados abaixo, imagine a situação que você precisa informar o estado onde mora o Carlos.

Tutorial PROCV - 00

 

Como estamos querendo saber uma informação do Carlos, obviamente apenas a linha do Carlos importa.

Tutorial PROCV - 00 a

 

Das informações que temos do Carlos, temos o Endereço, a Cidade e o Estado. Nesse exemplo, queremos a informação de Estado. Logo, queremos a 4ª coluna da nossa tabela (Lembra-se do "V" de Vertical da fórmula PROCV? É porque você define qual a coluna, dados que estão na vertical, irá apresentar a informação). A junção entre a linha (obtida pelo procura do nome) e a coluna (definida pela formula: 1, 2, 3, 4, etc) é a informação MG, a qual é a nossa resposta para a pergunta inicial.

Tutorial PROCV - 00 b

A fórmula PROCV funciona exatamente desta maneira: você realiza a busca de um valor em um intervalo e indica qual a coluna deseja.

Temos uma tabela de salários de uma empresa e você precisa consultar o salário de uma pessoa específica, o Sr. Ricardo Lopes. Utilize a fórmula PROCV para realizar essa tarefa:

Tutorial PROCV - 01

A fórmula utilizada é =PROCV(B12;B3:D6;3;0)

1º Atributo, B12. Representa o valor procurado, no caso o nome do empregado: Ricardo Lopes

2º Atributo, B3:D6. Representa a tabela ou intervalo de dados.

3º Atributo, 3. Representa a terceira coluna em nosso intervalo. Pois a informação que buscamos é o salário do empregado.

4º Atributo, 0. Representa que você deseja o valor exato para o salário, e não um valor aproximado.

O resultado desta fórmula será R$ 4.100,00, que é o salário do Ricardo Lopes.

Agora, com a mesma tabela de dados, você precisa do número de matrícula do empregado Ricardo Lopes ao invés do seu salário. Como essa informação está na segunda coluna de seu intervalo, você terá que mudar apenas o terceiro atributo. Veja:

Tutorial PROCV - 02

=PROCV(B12;B3:D6;2;0)

O resultado desta fórmula será 304077, que é o número de matrícula do Ricardo Lopes.

Considere abaixo as duas tabelas e que você precisa completar com a informação de peso na primeira tabela. Na segunda tabela, você tem a relação de embalagem x peso. Portanto, é possível preencher a primeira tabela com o peso utilizando a fórmula PROCV.

Tutorial PROCV - 07

 

Iremos começar pela célula C2, inserindo a serguinte fórmula: =PROCV(B2;E2:F5;2;0).

1º Atributo: B2. Pois procuramos a palavra VERDE

2º Atributo: E2:F5. É o intervalo de nossa tabela que iremos consultar. Note que não é necessário incluir a primeira linha (título)

3º Atributo: 2. Segunda coluna, pois é onde está a informação de peso no intervalo definido no 2º atributo.

4º Atributo: 0. Pois queremos o valor exato.

O resultado da fórmula é 1, pois para a embalagem VERDE seu peso é 1.

Tutorial PROCV - 08

 

Para complementar os demais itens, o usuário seleciona a célula com a fórmula e aplica para as demais células abaixo. Veja o problema que aconteceu: as últimas linhas aparecem um erro #N/D (veja depois, no final desse tutorial todos os possíveis erros informados pelo excel para o PROCV).

Tutorial PROCV - 09

 

Você sabe por que isso aconteceu?

Quando você arrasta a fórmula para as outras células, o excel modifica as células proporcionalmente à sua movimentação. Veja na imagem animada abaixo, que a medida que a fórmula foi descendo, o intervalo de procura também desceu. Para as últimas consultas (Produtos E, F, G e H), o intervalo de consulta ficou vazio e o Excel corretamente informou que não havia nada exibindo o erro #N/D

Tutorial PROCV - 10

 

Como corrigir?

Há duas maneiras de corrigir:

  • Travando o Intervalo

Ao escolher o intervalo de consulta, insira o carácter $ conforme a imagem abaixo. Há um atalho para fazer isso de maneira mais fácil, clique na fórmula e coloque o curso em cima do intervalo e aperte F4.

Tutorial PROCV - 11

 

  • Coluna como intervalo

Ao invés de escolher um intervalo limitado de linhas, escolha a coluna inteira.

Tutorial PROCV - 12

Outro erro bastante comum e que se deve ao fato do usuário não entender completamente o funcionamento dessa fórmula. Ao encontrar o valor procurado, o Excel imediatamente interrompe sua consulta. Quando seu intervalo de consulta não possui valores duplicados, você não terá problema. Caso seus dados apareçam mais de uma vez, você terá que se organizar antes. Vejamos um exemplo desse erro: na tabela abaixo a esquerda é um exemplo de um relatório de estoque. Caso o item esteja estocado em outra posição, teremos outra linha do item. Veja por exemplo o item A, que possui 3 linhas.

Tutorial PROCV - 13

 

Imagine que você precisa consultar o saldo em estoque dos produtos e resolve utilizar a fórmula PROCV. Inserimos a fórmula =PROCV(E2;A:C;3;0) nas células da coluna F. Perceba que os valores informados são sempre os primeiros encontrados (na ordem de cima para baixo) na nossa tabela. Dessa maneira, você não obtêm o resultado correto.

Tutorial PROCV - 14

 

Como resolver então?

O ideal para esse exemplo, seria criar uma tabela utilizando a fórmula SOMASE. Essa fórmula iria totalizar os quantitativos de cada item. Se fosse necessário uma consulta para saber o quantitativo (como por exemplo, a informação esteja sendo solicitada em outra aba do arquivo), o intervalo seria na tabela nova (que utilizamos o SOMA SE) e não no relatório de estoque.

 

Importante!

Criamos esse exemplo para exemplificar como a utilização equivocada da fórmula irá trazer resultados também equivocados. Como consequências, podemos tomar decisões extremamente erradas, como decidir comprar mais material.

Uma utilização bastante eficaz da fórmula PROCV é verificar se todos os valores de uma tabela estão em outra tabela, e vice-versa.

Tutorial PROCV - 15

 

Na célula B3, utilizamos a fórmula =PROCV(A3;D:D;1;0) para procurar o item do relatório 01 no relatório 02. Aplique a fórmula para todos os itens do relatório 01. Quando o resultado for #N/D, significa que o item (do relatório 01) não existe no relatório 02. Nesse exemplo, os itens B, T, E e F não estão no relatório 02.

Tutorial PROCV - 16

 

Faça o mesmo para os itens do relatório 02. Veja que os itens Z e W não existem no relatório 01.

Tutorial PROCV - 17

 

Quer personalizar o resultado?

Utilizamos as fórmulas SE e É.NÃO.DISP para construir a seguinte fórmula:  =SE(É.NÃO.DISP(PROCV(A3;D:D;1;0));"NÃO EXISTE";"EXISTE") e inserir na célula B3 e depois aplicar para todas as células. A informação de saída será EXISTE ou NÃO EXISTE.

Tutorial PROCV - 18

Esse erro é exibido quando o valor procurado não é encontrado no intervalo.

CAUSAS PROVÁVEIS:

  • VALOR NÃO EXISTE NO INTERVALO

No exemplo abaixo, foi colocado no primeiro atributo (valor procurado) a célula B12, que contem o nome Roberto Lopes. Perceba que na tabela de dados não há esse nome. Há um nome parecido, Ricardo Lopes, porém não é igual. O Excel então retorna a função com o erro #N/D

Tutorial PROCV - 03

 

  • INTERVALO DEFINIDO INCORRETAMENTE

Já nesse exemplo, o valor procurado (Pedro Gomes, célula B12) até existe, porém a definição do intervalo na fórmula foi mal feita. Veja que o valor (Pedro Gomes) na tabela está na linha 6 e o intervalo definido na fórmula foi até a linha 5. Logo, o Excel não encontra o valor procurado e retorna como erro #N/D.

Tutorial PROCV - 04

 

Esse erro é exibido quando o número da coluna é igual a 0 (ZERO). O mínimo valor para esse atributo é 01.

Tutorial PROCV - 05

 

Esse erro é exibido quando o número da coluna indicado é maior que o número de colunas do intervalo. No exemplo abaixo, o intervalo tem 3 colunas porém foi inserido no fórmula, o valor de 4 para o número da coluna. Obviamente, o excel não irá conseguir realizar a operação e retornará como erro #REF!

Tutorial PROCV - 06

DOWNLOAD DA PLANILHA

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

SUBIR